Flexmls Will Require Browsers To Support TLS 1.2 For Security

Jun 13, 2018  |  Katelyn Renner

As part of FBS’s ongoing commitment to security, Flexmls will require your browser to support Transport Layer Security protocol 1.2 (TLS 1.2).

TLS 1.2 is an industry standard designed to protect the privacy of information communicated over the internet. This change might sound intimidating, but it should have no impact and require no action for the majority of users because the current versions of all the major browsers already support TLS 1.2.

When will it change?
This update will happen on July 1, 2018.

What does this mean for me?
If you already use current, up-to-date browsers and computers (or phones, tablets, and other devices), you should not even notice this change. However, older browsers may not recognize the new TLS 1.2 protocol and might have problems accessing the Flexmls System once this upgrade is in place.


How can I test my browser and computer?
To help you determine whether your browser or computer (or phone, tablet, or other device) will work with the new TLS 1.2 protocol, please click the following link to test your current browser’s capabilities: https://www.ssllabs.com/ssltest/viewMyClient.html 

If you see “Your user agent has good protocol support,” then your browser will support the upcoming changes, and there’s no action you need to take.

Note: Make sure to click on the link from every computer (or phone, tablet, or other device) and browser you use to access the Flexmls System. Testing from each computer and browser you use to access the Flexmls System is important because different browsers on the same computer (or different computers running the same browser) have different capabilities and should be tested independently.

What if one of my browsers or computers fails the compatibility test?
If the test page doesn’t report that your user agent has good protocol support, that means your browser or computer will need to be upgraded to a version that supports TLS 1.2. You can find a compatibility chart at the following web site: https://www.ssllabs.com/ssltest/clients.html

Once your computer and browser have been updated to the most recent version, check the test page again and you should pass.

Why are we making this update?
This update is being made in response to an industry-wide move toward maintaining PCI compliance by discontinuing support for TLS 1.0/1.1 and using TLS 1.2. More information about the move to TLS 1.2 can be found here.